TV Mosaic no webinterface

TVMosaic live and recorded TV products for Desktop/NAS/Raspbery Pi
Post Reply
Sillion
Posts: 3
Joined: Sun Jan 06, 2019 4:21 pm

TV Mosaic no webinterface

Post by Sillion » Sun Jan 06, 2019 4:54 pm

I have installed TV Mosaic on OSMC but i have no webinterface
root@osmc:~# cat /proc/version
Linux version 4.14.78-4-osmc (root@vero3-db) (gcc version 6.3.0 20170516 (Debian 6.3.0-18+deb9u1)) #1 SMP PREEMPT Wed Dec 12 17:58:11 UTC 2018
root@osmc:~#

root@osmc:~# uname -a
Linux osmc 4.14.78-4-osmc #1 SMP PREEMPT Wed Dec 12 17:58:11 UTC 2018 armv7l GNU/Linux

root@osmc:~# cat /etc/debian_version
9.6

root@osmc:~# sudo /etc/init.d/tvmosaic restart
[ ok ] Restarting tvmosaic (via systemctl): tvmosaic.service.
root@osmc:~#
2019-Jan-06 17:16:29: Logging is started
2019-Jan-06 17:16:29: ==============================================================
2019-Jan-06 17:16:29: ---------------------------
2019-Jan-06 17:16:29: Server info:
2019-Jan-06 17:16:29: TV Mosaic, 1.0.0, 17051
2019-Jan-06 17:16:29: platform id: d37d1c13-0891-4c2b-a035-c0bb5b4f0f1c
2019-Jan-06 17:16:29: ---------------------------
2019-Jan-06 17:16:29: [E] component_manager_t::start. Start for 8a4c61b0-7bba-4c22-a322-62ed39897e0e has returned error 6
2019-Jan-06 17:16:31: [E] network_server_t: bind: Address already in use
2019-Jan-06 17:16:31: [E] network_server_t: port 9271 is not available
2019-Jan-06 17:16:32: [E] network_server_t: bind: Address already in use
2019-Jan-06 17:16:32: [E] network_server_t: port 9270 is not available
2019-Jan-06 17:16:32: [E] network_server_t::start. Error starting http server on port 9270
2019-Jan-06 17:16:32: [E] network_server_t::start(): discovery_server - bind() failed

Sillion
Posts: 3
Joined: Sun Jan 06, 2019 4:21 pm

Re: TV Mosaic no webinterface

Post by Sillion » Thu Jan 10, 2019 10:44 pm

Nobody has an idea why it does not work
The same problem I have also under Debian.

the_man
Site Admin
Posts: 145
Joined: Fri Jan 06, 2017 1:13 pm

Re: TV Mosaic no webinterface

Post by the_man » Fri Jan 11, 2019 10:59 am

TVMosaic server does not have a web UI, yet.
As for 2019-Jan-06 17:16:31: [E] network_server_t: port 9271 is not available
Looks like ports 9270-9271 are busy, maybe by some other app or so.

Sillion
Posts: 3
Joined: Sun Jan 06, 2019 4:21 pm

Re: TV Mosaic no webinterface

Post by Sillion » Sun Jan 13, 2019 7:27 pm

And how to configure tvmosaic

the_man
Site Admin
Posts: 145
Joined: Fri Jan 06, 2017 1:13 pm

Re: TV Mosaic no webinterface

Post by the_man » Mon Jan 14, 2019 11:02 am

From any TVMosaic which installed on the desktop with the UI.

Post Reply