Installation on Raspberry Pi fails

TVMosaic live and recorded TV products for Desktop/NAS/Raspbery Pi
Post Reply
JBX077
Posts: 9
Joined: Fri Dec 14, 2018 8:34 am

Installation on Raspberry Pi fails

Post by JBX077 » Sat Dec 22, 2018 3:42 pm

Hi,

I downloaded TVmosaic from the website and transferred it to the Pi. Now when I run the installation command I get this:
(i tried again after updating the Pi, that's why you see some information about "old pre-removal".
sudo dpkg -i tvmosaic-raspberry-linux-armhf_raspbian-1.0.0.deb
(Reading database ... 35147 files and directories currently installed.)
Preparing to unpack tvmosaic-raspberry-linux-armhf_raspbian-1.0.0.deb ...
Illegal instruction
dpkg: warning: subprocess old pre-removal script returned error exit status 132
dpkg: trying script from the new package instead ...
dpkg: ... it looks like that went OK
Unpacking tvmosaic (1.0.0) over (1.0.0) ...
upgrade
Setting up tvmosaic (1.0.0) ...
Illegal instruction
dpkg: error processing package tvmosaic (--install):
subprocess installed post-installation script returned error exit status 132
Processing triggers for systemd (232-25+deb9u6) ...
Errors were encountered while processing:
tvmosaic
sudo dpkg --configure tvmosaic
Setting up tvmosaic (1.0.0) ...
cp: cannot stat '/usr/local/bin/tvmosaic/shared.inst/*': No such file or directory
dpkg: error processing package tvmosaic (--configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
tvmosaic

the_man
Site Admin
Posts: 153
Joined: Fri Jan 06, 2017 1:13 pm

Re: Installation on Raspberry Pi fails

Post by the_man » Thu Dec 27, 2018 3:05 pm

What OS is installed on your RPI?

db82407
Posts: 2
Joined: Sat Mar 02, 2019 9:34 pm

Re: Installation on Raspberry Pi fails

Post by db82407 » Sat Mar 02, 2019 9:48 pm

I've just downloaded Version: 1.0.0 Build: 17217 for Raspberry Pi and attempted to install it on the latest Raspbian Stretch (Linux raspberrypi 4.14.79+ #1159 Sun Nov 4 17:28:08 GMT 2018 armv6l GNU/Linux).

It fails with an Illegal Instruction, in the same way as described in the original post.

$ sudo dpkg -i tvmosaic-raspberry-linux-armhf_raspbian-1.0.0.deb
Selecting previously unselected package tvmosaic.
(Reading database ... 93721 files and directories currently installed.)
Preparing to unpack tvmosaic-raspberry-linux-armhf_raspbian-1.0.0.deb ...
Unpacking tvmosaic (1.0.0) ...
Setting up tvmosaic (1.0.0) ...
Illegal instruction
dpkg: error processing package tvmosaic (--install):
subprocess installed post-installation script returned error exit status 132
Processing triggers for systemd (232-25+deb9u6) ...
Errors were encountered while processing:
tvmosaic

db82407
Posts: 2
Joined: Sat Mar 02, 2019 9:34 pm

Re: Installation on Raspberry Pi fails [SOLVED]

Post by db82407 » Wed Mar 06, 2019 8:59 am

I forgot to mention I was using a Pi Zero W, which uses ARMV6:

$ uname -a
Linux raspberrypi 4.14.79+ #1159 Sun Nov 4 17:28:08 GMT 2018 armv6l GNU/Linux

ARMV6 is a subset of ARMV7 used on Pi 2 and 3, which is why I was getting Illegal Instruction.

--
Derek

thunderBucket
Posts: 1
Joined: Tue Oct 29, 2019 9:59 am

Re: Installation on Raspberry Pi fails

Post by thunderBucket » Tue Oct 29, 2019 10:10 am

Hi db82407 (Derek)

I am getting the same issue, on RPi ZeroW (buster 10.1).

My knowledge of RPi is limited and I don't understand the post about ARM versions but I suspect it could point me to the answer!

So, any help will be appreciated

With kind regards
JB

Post Reply