After Important TVMosaic security update - IOS and ATV app not working!

General discussions about TV Mosaic application.
Post Reply
Ritzee
Posts: 24
Joined: Wed Apr 04, 2018 4:21 pm

After Important TVMosaic security update - IOS and ATV app not working!

Post by Ritzee » Wed May 01, 2019 7:56 pm

Today I received an email with the title "Important TVMosaic security update"..
Something to do with hacking your stream outside your network..
I do not use TVM outside my network, but this looks important, so install the thing..

After this, tv streams do function except for the recorded TV. On OSX the items are there but not on IOS (ipad, iphone and more important Apple TV)

Yes, did rebuild the database, restarted all apps and hardware again but no luck.

When opening the AppleTV, normal TV streaming works, but the app crashes on trying to acces the recorded TV.

Please Help! Any chance on rollback to the previous version?

Tom42935
Posts: 2
Joined: Wed May 23, 2018 6:35 pm

Re: After Important TVMosaic security update - IOS and ATV app not working!

Post by Tom42935 » Wed May 01, 2019 8:03 pm

confirmation on all iOS devices... :( Zero recordings...
macOS ok
(no test with AppleTV done)
Regards Thomas

Ritzee
Posts: 24
Joined: Wed Apr 04, 2018 4:21 pm

Re: After Important TVMosaic security update - IOS and ATV app not working!

Post by Ritzee » Wed May 01, 2019 8:07 pm

&%# wished it was only me.. any suggestions? Rolling back?

freddy
Posts: 36
Joined: Tue Apr 10, 2018 11:53 am

Re: After Important TVMosaic security update - IOS and ATV app not working!

Post by freddy » Wed May 01, 2019 8:35 pm

I’ll post full details of my setup tomorrow, but yes i can confirm i also have no recordings shown from within the iOS client with this latest version

I resolved it by rolling back my Synology and Linux server/clients to the previous version - suggest you do likewise.

Don't forget to backup your server configuration settings before uninstalling ...

Ritzee
Posts: 24
Joined: Wed Apr 04, 2018 4:21 pm

Re: After Important TVMosaic security update - IOS and ATV app not working!

Post by Ritzee » Wed May 01, 2019 8:44 pm

Log says..

rtv_control_t::get_objects. Request for unknown source id

019-May-01 21:41:51: [E] rtv_control_t::get_objects. Request for unknown source id xxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxx
2019-May-01 21:41:54: [E] rtv_control_t::get_objects. Request for unknown source id xxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxx
2019-May-01 21:42:10: [E] rtv_control_t::get_objects. Request for unknown source id xxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxx
2019-May-01 21:43:24: [E] rtv_control_t::get_objects. Request for unknown source id xxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxx
2019-May-01 21:43:28: [E] rtv_control_t::get_objects. Request for unknown source id xxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxx
2019-May-01 21:43:30: [E] rtv_control_t::get_objects. Request for unknown source id xxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxx
2019-May-01 21:43:32: [E] rtv_control_t::get_objects. Request for unknown source id xxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxx
2019-May-01 21:43:34: [E] rtv_control_t::get_objects. Request for unknown source id xxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxx
2019-May-01 21:43:51: [E] rtv_control_t::get_objects. Request for unknown source id xxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxx
2019-May-01 21:43:53: [E] rtv_control_t::get_objects. Request for unknown source id xxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxx
2019-May-01 21:43:55: [E] rtv_control_t::get_objects. Request for unknown source id xxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxx
2019-May-01 21:44:48: [E] rtv_control_t::get_objects. Request for unknown source id xxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxx
2019-May-01 21:44:51: [E] rtv_control_t::get_objects. Request for unknown source id xxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxx
2019-May-01 21:44:54: [E] rtv_control_t::get_objects. Request for unknown source id xxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxx

everytime I try to access the recorded tv list via appletv, ipad or iphone

Montoya
Posts: 204
Joined: Mon Feb 26, 2018 9:07 am

Re: After Important TVMosaic security update - IOS and ATV app not working!

Post by Montoya » Wed May 01, 2019 9:02 pm

DVBLink server 6.0.0 build14499, DVBLink TVSource 6.0.0 build14061, DVBLink for IPTV build 13107
TVMosaic server build 17550, Kodi 18.2 (Git:20190422-f2643566d0), Win10 Pro x64 1809 build17763.437

Oberon
Posts: 1269
Joined: Thu Jan 26, 2017 8:45 am

Re: After Important TVMosaic security update - IOS and ATV app not working!

Post by Oberon » Thu May 02, 2019 5:44 am

New build 17550 fixes the issue.

Tom42935
Posts: 2
Joined: Wed May 23, 2018 6:35 pm

Re: After Important TVMosaic security update - IOS and ATV app not working!

Post by Tom42935 » Thu May 02, 2019 6:56 am

thanks, iOS dev. are working with recorded content :)

Post Reply