Issues with migration from dvblink to kodi v18

Topics about Android / Amazon / iOS / AppleTV / Kodi and other TVMosaic clients
debutanker
Posts: 24
Joined: Tue Mar 20, 2018 8:10 pm

Re: Issues with migration from dvblink to kodi v18

Post by debutanker » Thu Sep 13, 2018 3:42 pm

Many thanks for having a look into this - also couldn´t really find something which might be related to my issues.

But the only thing which has changed since yesterday, was this update to Milhouse #0912 and some windows 10 updates (server machine) and from out of nowhere, my problems are gone...

Will test some more days and keep you informed.

debutanker
Posts: 24
Joined: Tue Mar 20, 2018 8:10 pm

Re: Issues with migration from dvblink to kodi v18

Post by debutanker » Mon Sep 17, 2018 7:47 am

So after 3 days it really seems, that build #0912 fixed this issue for me - tested with build #911 and the problem occured again.
I've also noticed little changes in starting behavior on my clients with build #0912. With previous builds i had no delays in kodi pvr menu for e.g. 'recently played channels' or 'recent recordings', now i see 'the kodi busy circle' for about 10 seconds....(see attachment).
So it seems that maybe something in network accessing has changed!?
FullSizeRender.jpg
FullSizeRender.jpg (99.11 KiB) Viewed 479 times

debutanker
Posts: 24
Joined: Tue Mar 20, 2018 8:10 pm

Re: Issues with migration from dvblink to kodi v18

Post by debutanker » Tue Sep 18, 2018 11:38 am

It seems to be this PR which is involved ---> https://forum.kodi.tv/showthread.php?ti ... pid2768566

debutanker
Posts: 24
Joined: Tue Mar 20, 2018 8:10 pm

Re: Issues with migration from dvblink to kodi v18

Post by debutanker » Mon Sep 24, 2018 11:56 am

All back to start...
Since build #0921 this issue has returned for me.
Team Kodi (ksooo) mentioned something about "the addon must implement async connect" - > https://forum.kodi.tv/showthread.php?ti ... pid2776951
https://github.com/kodi-pvr/pvr.dvblink/issues/106

debutanker
Posts: 24
Joined: Tue Mar 20, 2018 8:10 pm

Re: Issues with migration from dvblink to kodi v18

Post by debutanker » Tue Oct 23, 2018 8:19 am

Is there any progress in terms of "async connect"?

Oberon
Posts: 1130
Joined: Thu Jan 26, 2017 8:45 am

Re: Issues with migration from dvblink to kodi v18

Post by Oberon » Tue Oct 23, 2018 8:23 am

debutanker wrote:
Tue Oct 23, 2018 8:19 am
Is there any progress in terms of "async connect"?
No, not yet

tehax
Posts: 29
Joined: Sat Mar 24, 2018 9:10 am

Re: Issues with migration from dvblink to kodi v18

Post by tehax » Tue Oct 23, 2018 6:48 pm

Is it planed? I also looking forward to see that the Kodi pvr addin will get further features and updates.

debutanker
Posts: 24
Joined: Tue Mar 20, 2018 8:10 pm

Re: Issues with migration from dvblink to kodi v18

Post by debutanker » Sun Nov 11, 2018 4:13 pm

tehax wrote:
Tue Oct 23, 2018 6:48 pm
Is it planed? I also looking forward to see that the Kodi pvr addin will get further features and updates.
I'd also love to see some further adjustments in the light of the evolution of Kodi 18 (RC1).

Oberon
Posts: 1130
Joined: Thu Jan 26, 2017 8:45 am

Re: Issues with migration from dvblink to kodi v18

Post by Oberon » Tue Nov 13, 2018 4:10 pm

debutanker wrote:
Mon Sep 24, 2018 11:56 am
All back to start...
Since build #0921 this issue has returned for me.
Team Kodi (ksooo) mentioned something about "the addon must implement async connect" - > https://forum.kodi.tv/showthread.php?ti ... pid2776951
https://github.com/kodi-pvr/pvr.dvblink/issues/106
How reproducible is the issue on your system?
We have looked through the log files and it does not seem to be related to the async connect.
The server is available and kodi client gets all required information from it - channels, recordings etc., including a streaming url. It just that stream does no come for one or another reason. I also do not see the request for stream in the logs.
So we are back to the square one.
Can you, please, upload a fresh set of logs (both kodi and tvmosaic server with info log level) when the issue resurfaces? We will take it up further from there.

debutanker
Posts: 24
Joined: Tue Mar 20, 2018 8:10 pm

Re: Issues with migration from dvblink to kodi v18

Post by debutanker » Wed Nov 14, 2018 11:00 am

Oberon wrote:
Tue Nov 13, 2018 4:10 pm
debutanker wrote:
Mon Sep 24, 2018 11:56 am
All back to start...
Since build #0921 this issue has returned for me.
Team Kodi (ksooo) mentioned something about "the addon must implement async connect" - > https://forum.kodi.tv/showthread.php?ti ... pid2776951
https://github.com/kodi-pvr/pvr.dvblink/issues/106
How reproducible is the issue on your system?
We have looked through the log files and it does not seem to be related to the async connect.
The server is available and kodi client gets all required information from it - channels, recordings etc., including a streaming url. It just that stream does no come for one or another reason. I also do not see the request for stream in the logs.
So we are back to the square one.
Can you, please, upload a fresh set of logs (both kodi and tvmosaic server with info log level) when the issue resurfaces? We will take it up further from there.
Still reproducible with latest Milhouse build #1113.

Heres the log with activated timeshift and broken playback - > http://ix.io/1rR9
Heres the log with deactivated timeshift and successful playback - > http://ix.io/1rRe
Server log - > https://pastebin.com/jPhmtm8q

Post Reply