Page 1 of 2

Path for recorded TV

Posted: Thu Nov 01, 2018 3:45 pm
by johnm0101
I am making progress on evaluating TVMosaic and possibly shifting over from DVBlink
Cant use Synology anymore bah humbug

Anyway got a nice Win10 silent pc server up and runiing almost ready to jump

Read the (meagre) instructions on migrating database

However I find I cannot use the NAS path I previously used with DVBlink

I map a drive say '"x:\" and point to x:\recorded tv"

TV_mosaic goes into a permanent loop - have to invole task manager to stop it
The internal 'fileOPen'dialog for selecting folders and drives will not show the mapped drive

Is it possible to record to a network path on TVMosaic ?


JM

Re: Path for recorded TV

Posted: Thu Nov 01, 2018 3:52 pm
by johnm0101
Further to last - I rebooted and started tvmosaic again but when I try to access the settings / recorder tab it now goes into the same loop of death.
is there a config file somewhere I can edit to remove my 'X:/recorde tv" path

question remains is there any way to record to a network path?

Re: Path for recorded TV

Posted: Thu Nov 01, 2018 7:10 pm
by Oberon
Windows service, running as local system account, cannot access network drives. You need to change it to one of the users of your windows system to be able to access network drives.

Re: Path for recorded TV

Posted: Fri Nov 02, 2018 7:51 am
by johnm0101
tx Oberon you are such a fund of useful abstruse info about this all works :-)

not entirely sure I understand what you mean by different logon the service so I called up service manger looked at TVMosaic and found a tab 'logon' which allowed me to change from a local account to a specific named account - I presume this is what you mean?

This has resulted in me being able to see and select folders on the Synology NAS but 1) I do not see the mapped drive 'a la' windows folder structure but the raw linux file structure on the synology nas. No big deal I can find my recorded TV folder under @public.
I am however unable now to see the local drives--- very strange. I'll keep on fiddling

Anyway one last question - I have all these old recordings from a synology nas version of dvblink but no database(the nas's have been upgraded a couple of times and no back up). Is there a way of getting such recordings into the tvmosaic database ?
I note the database is sqlite - I am pretty familiar with that in another environment - if there's no easy way to get the old recordings into the database other than manually can you give me a heads up on which sqlite files and where and what content is needed


Tia
JM

Re: Path for recorded TV

Posted: Tue Feb 26, 2019 7:49 pm
by dr.falcuccio
I got stuck with this also, after setting a mapped drive path as recording location. Changing the service login from system to admin user did not help - tvmosaic kept getting stuck. The relevant config file is in

C:\Program Files (x86)\DVBLogic\TVMosaic\data\config\recorder_settings.xml

I needed to set ownership rights to the file in question, in order to be able to edit it.

Hopefully this saves someone else a bit of frustration down the road. :)

Re: Path for recorded TV

Posted: Tue Oct 01, 2019 11:48 pm
by meldgaard
I have tried to follow the steps above, but stille get a permanent loop when entering "settings" and the "recorder"

I have change the Windows service user from local to my default user in the "built in Service app in windows"
I have the changes the recorder_settings.xml file and put in my new path (z:\recording)
Nothing works...

Any advices?

I also think, that selecting a mapped network drive should be petty much standard in TV Mosaic...

Re: Path for recorded TV

Posted: Thu Oct 03, 2019 3:30 pm
by dr.falcuccio
@meldgaard,

what I meant to convey with my post about editing recorder_settings.xml was simply offering a way to get tv-mosaic to work again, by setting a local path in the settings.

didn't mean to suggest that by doing that *any* non-local path would work. Unfortunately not being able to use a full server path (\\...) or a mapped drive was a limitation of the software (and looks as though it still is). Changing service user did not make any difference for me either ,when I tried.

Re: Path for recorded TV

Posted: Sat Oct 26, 2019 2:48 pm
by HansDampf
Oberon wrote:
Thu Nov 01, 2018 7:10 pm
Windows service, running as local system account, cannot access network drives. You need to change it to one of the users of your windows system to be able to access network drives.
Hello Oberon,

today, I came across your post above. Could you please formulate in more detail what I have to do here? I understand so far that I have to select a special login name for the service 'tvmosaic_server'. The system offers me:

Administrator
DefaultAccount
defaultuser ()
guest
Local service -> this is probably not enough
Network Service
WDAUtilityAccount
<my username>

However, for the most part, the passwords are not available to me. Can you help me?
Thank you...

Re: Path for recorded TV

Posted: Mon Nov 25, 2019 9:17 am
by TheRealBamse
@Oberon

I'm having the same issue as above.
I'd also like to know whether there's a solution.

I've moved an old DVBLink install on a Synology NAS to a small form factor Windows PC but I want to continue using my NAS for storage - for obvious reasons.

I've tried moving Windows service to a different user as described above. No result.

To be brutally honest and as a Software Dev myself, I'm very much failing to see why an organisation would spend time on a "Send To"-function if it's limited to moving recordings around on the same drive.
IMHO this problem should really have been picked up when the team assessed the functionality's value.

Re: Path for recorded TV

Posted: Mon Nov 25, 2019 4:12 pm
by HansDampf
Hello TheRealBamse,

TVMosaic's support team prefers to communicate via PM rather than through this forum. I've had a lot of email traffic with a supporter in the last few weeks. To abbreviate the whole I copy here my last post (summary of the posts), as well as the last statement from the support:
----------------------------

######.######@t-online.de, said 11 days ago
Hello ######,

I'll summarize:
I need the file system for recorded *. TS - files moving from the installation directory (C:-ProgramData-DVBLogic-TVMosaic-data-RecordedTV) to an external file system (NAS). Background: Drive C: is an SSD with only 512 GB capacity. The location for the 'recorder_database' is according to installation on C:'ProgramData'DVBLogic'TVMosaic'recorder_database.

Currently (as of today) the directory 'RecordedTV' is on my NAS. Deployment is through an iSCSI initiator service from Microsoft. There are no initialization, timing or capacity issues as you indicated. I can record more than five TV channels at a time without losing quality. (The only problem here is that during computer initialization, the connection of all iSCSI drives is sometimes 'missed'. (See also Post #66792). However, the problem is fixed after a reboot (until next time).)

Now I'm trying to replace the iSCSI connection with 'shares' on the NAS and 'Connect network drive' on the WIN 10 page. The crashes appear as described in Begin's post. The last attempt was to provide the same user with the same password and same fixes on the NAS and win 10. I have attached the individual steps:

Step 1: - Dialog 'Properties of tvmosaic_server'
Step 2: - Dialog 'User Search', here: MediaStorageAdmin'
Step 3: - Dialog 'Takeover of Found Users'
Step 4: - Dialog 'Password assignment of these users'
Step 5: - Dialog 'Confirmation & Activation after exit + Restart of service'
Step 6: - Error message when starting TVMosaic 'False HW Fingerprint'

As soon as I switch back to 'Local System Account', the license keys are fine again when TVMosaic starts (better: the error message 'False HW Fingerprint' is omitted. I can switch this back and forth at will. There is no hardware change (or software change).

To put it in a nutshell, what do I need to do to give the service 'tvmosaic_server' the correct permissions, and if necessary receive a new set of license keys?

rar
Pictures.rar
(322 KB)

######, said 3 days ago
Hi ######.######@t-online.de,
Apologies for the late response.
We have put all data from your ticket into task which was created a few weeks ago.
At the moment after first iteration task was marked with Low priority flag. Due to same thing as i wrote: network paths are not officially supported.
Anyway it is in the list. Can't give any guarantee if there will be done something in the near future.


Kind regards,
DVBlogic support team

Ticket: https://dvblogic.freshdesk.com/helpdesk/tickets/66791