IPTV channels: no audio

TVMosaic live and recorded TV products for Desktop/NAS/Raspbery Pi
ruedi61
Posts: 7
Joined: Sat Jun 02, 2018 5:19 pm

IPTV channels: no audio

Post by ruedi61 » Tue Jun 05, 2018 6:21 am

ah yes, thanks a lot! The Radio Station's are now under "Radio", but no Sound came.
I tried various m3u Lists, like: <censored by admin>

Can you check, if this Playlist work correctly this way?

Oberon
Posts: 1288
Joined: Thu Jan 26, 2017 8:45 am

Re: IPTV channels: no audio

Post by Oberon » Tue Jun 05, 2018 7:18 am

Are all channels without sound or only some?
What is the client that you use and on which platform?

ruedi61
Posts: 7
Joined: Sat Jun 02, 2018 5:19 pm

Re: IPTV channels: no audio

Post by ruedi61 » Tue Jun 05, 2018 3:01 pm

All Channels are without Sound...
On all Clients (Android, raspberry(over Kodi & DVBLink PVR Client), Windows TV-Mosaic).

Oberon
Posts: 1288
Joined: Thu Jan 26, 2017 8:45 am

Re: IPTV channels: no audio

Post by Oberon » Tue Jun 05, 2018 3:06 pm

And if you play this playlist in VLC - is there sound?

ruedi61
Posts: 7
Joined: Sat Jun 02, 2018 5:19 pm

Re: IPTV channels: no audio

Post by ruedi61 » Tue Jun 05, 2018 4:34 pm

Yes, in VLC Player (Windows) works with Sound.

Oberon
Posts: 1288
Joined: Thu Jan 26, 2017 8:45 am

Re: IPTV channels: no audio

Post by Oberon » Wed Jun 06, 2018 8:33 am

Correct, it will not play, unfortunately.
Most of the channels in your playlist are mp3 radio channels, while TVMosaic only works with (at least, at the moment) with the channels, delivered as transport stream.
We will put it on our todo, but no ETA can be given at the moment.

nils12
Posts: 7
Joined: Wed Jan 23, 2019 2:20 pm

Re: IPTV channels: no audio

Post by nils12 » Wed Jan 23, 2019 2:26 pm

Hi,
i have similar issue, with all my "local" iptv channels encoded by myself.

Works on VLC and i do not believe its mp3 format, here is a print screen of vlc codec information:




Image

Oberon
Posts: 1288
Joined: Thu Jan 26, 2017 8:45 am

Re: IPTV channels: no audio

Post by Oberon » Wed Jan 23, 2019 2:30 pm

nils12 wrote:
Wed Jan 23, 2019 2:26 pm
Hi,
i have similar issue, with all my "local" iptv channels encoded by myself.

Works on VLC and i do not believe its mp3 format, here is a print screen of vlc codec information:
If you have control over audio encoding for those channels, I recommend that you change audio codec to AAC. Then audio will start working in TVMosaic.

nils12
Posts: 7
Joined: Wed Jan 23, 2019 2:20 pm

Re: IPTV channels: no audio

Post by nils12 » Wed Jan 23, 2019 3:39 pm

Oberon, much appreciate the response,

yes i do have control, however encoding require cpu if i am not wrong, i was hoping just to transcode. its weird, because when i test the "source" on your application it works fine, but when i test the transcoded ffmpeg url it does not work, and i simply use "copy" command .

I hope you soon support more audio format.

Oberon
Posts: 1288
Joined: Thu Jan 26, 2017 8:45 am

Re: IPTV channels: no audio

Post by Oberon » Wed Jan 23, 2019 3:43 pm

Transcoding is decoding + encoding.
What is the exact ffmpeg command line that you are using?

Post Reply