Page 5 of 6

Re: Test: Anyone willing to test TVMosaic Docker container?

Posted: Wed May 15, 2019 7:44 pm
by ampeer
There might be a problem regarding the time(zone). I tried to record the "Tagesschau" news at 20:00. Playing around with the "Start before" and "Start after" settings turned out that I need to set both values to 18:00!! to match the 20:00 schedule!

Re: Test: Anyone willing to test TVMosaic Docker container?

Posted: Fri May 17, 2019 8:28 am
by Oberon
ampeer wrote:
Wed May 15, 2019 7:44 pm
There might be a problem regarding the time(zone). I tried to record the "Tagesschau" news at 20:00. Playing around with the "Start before" and "Start after" settings turned out that I need to set both values to 18:00!! to match the 20:00 schedule!
This is very strange. The docker container by default synchronizes date/time with the host. Let's see if anyone else reports this as well.

Re: Test: Anyone willing to test TVMosaic Docker container?

Posted: Sun May 19, 2019 8:00 am
by Fredje_B
Hello all,

When accessing the server from an IOS plateforme (Apple TV or iPhone), the refresh of the TV Guide never ends, I get the "Loading" wheel indefinitely. The refresh of the Media Library works well but not all movies/TV show are displayed.

I have tried with the two version of the container actually available : 75563 & 75569. The container runs on a Synology NAS.

On the desktop version (on a Mac), there is no issue with the TV Guide.

When using the desktop version from my Mac as a Server, the TV Guide display instantly on the IOS plateforme.

Is there any specific port to open for the TV Guide? I have actually mapped the ports 9270, 9271, 9370 & 9371

Regards,

Fredje

Re: Test: Anyone willing to test TVMosaic Docker container?

Posted: Sun May 19, 2019 9:00 am
by ampeer
Hi Fredje,

sorry to tell that I cannot reproduce this running the docker container on my synology and accessing the client from an iPad.

It's just that the Edit Schedule dialog is somehow broken on the Start and Stop drop down:
screenshot.jpg
screenshot.jpg (365.1 KiB) Viewed 1423 times
I don't know though if this is Docker related...

Re: Test: Anyone willing to test TVMosaic Docker container?

Posted: Sun May 19, 2019 10:34 am
by Fredje_B
@ampeer Thx for the clarification on your iPad. Good to know it is running.

No idea for the schedule issue, I would like to get so far ;-)

Fredje

Re: Test: Anyone willing to test TVMosaic Docker container?

Posted: Sun May 19, 2019 11:27 am
by Fredje_B
I have sniffed the traffic network coming out of the app and could see that the issue was the long list of channels I have for which the app try to download all the images prior to display the EPG.

Reducing the list to a few channels has helped to have the EPG almost instantly.

Think the team should change the way the EPG is displayed...just display as soon as you have data and download the rest in background. Also make use of caching to not download again the images as soon as you ask for the EPG.

Regards,

Fredje

Re: TVMosaic Docker container topic

Posted: Sat May 25, 2019 11:10 am
by ampeer
Yesterday I successfully upgraded to the new release using the "latest" docker image without any issues.

Existing issues persist though:
- time for schedule (before/after) still 2 hours offset (all other times are accurate, in EPG for example, NAS is running on Europe/Berlin GMT+1)
- start / stop minutes earlier / later on iOS schedule view still broken

Re: TVMosaic Docker container topic

Posted: Sat May 25, 2019 11:14 am
by Oberon
ampeer wrote:
Sat May 25, 2019 11:10 am
- time for schedule (before/after) still 2 hours offset (all other times are accurate, in EPG for example, NAS is running on Europe/Berlin GMT+1
It looks like time settings of your NAS or container are incorrect.
First, check the date/time settings of your NAS.
If they are correct, check date time inside the container. To do this, execute from the host command line

Code: Select all

docker exec -it <container id> /bin/bash
and then, once inside the container shell

Code: Select all

date

Re: TVMosaic Docker container topic

Posted: Sat May 25, 2019 11:28 am
by ampeer
Thanks @Oberon,

you are indeed right. The time inside the container is wrong:
Bildschirmfoto 2019-05-25 um 13.24.22.png
Bildschirmfoto 2019-05-25 um 13.24.22.png (31.7 KiB) Viewed 1351 times
This screenshot was taken at 13:23 which matches exactly the 2 hours offset that occurs in the schedule window.

Need to find out how to fix this.

Re: TVMosaic Docker container topic

Posted: Sat May 25, 2019 11:35 am
by ampeer
Fixed by adding that line to my docker-compose.yaml file:

Code: Select all

    environment:
      TZ: "Europe/Berlin"