Page 1 of 2

TVMosaic, Windows10, Oscam

Posted: Thu May 02, 2019 8:38 am
by TribunMaximus
Hi there,

I' looking for somehow who can help me to get my Oscam running on windows 10 together with TV Mosaic. Or an good How-To as well. ;-)
My problem:
In ..../devices/CINERGY_S2..../plugins I have the following files:
dvbjcam.conf, dcbjcam.dll, dvbjcam.readers. So far so good.

And this is my reader in dvbjcam.readers:

Code: Select all

[reader]
label                         = share
protocol                      = cccam
device =xxx.xxx.xxx.xx,xxxxx
user = xxxxxxx
password = xxxxxx
inactivitytimeout             = 300
group                         = 1
disablecrccws                 = 1
cccversion                    = 2.3.0
I think this is correct because it is working on another PC with DVB-Viewer fine.

Which other kind of settings have to be done and which kind of Oscam-Server do I need to setup (the same as or DVB-Viewer?)?
And how to setup this correctly to work fine with TVMosaic.

Thanks for your help!

Br
Jens

Re: TVMosaic, Windows10, Oscam

Posted: Thu May 02, 2019 8:39 am
by Oberon

Re: TVMosaic, Windows10, Oscam

Posted: Thu May 02, 2019 8:46 am
by TribunMaximus
Thanks for this link, I already checked this out.
This one is for Synology and not for Windows. :-(

So maybe here is someone to help me with this anyway?

Where oscam.server, oscam.user and oscam.conf needs to me stored?

Br
Jens

Re: TVMosaic, Windows10, Oscam

Posted: Thu May 02, 2019 8:54 am
by Oberon
On windows oscam config files - user, conf and server have to be stored in the root of the oscam installation folder - where your oscam.exe resides.

Re: TVMosaic, Windows10, Oscam

Posted: Thu May 02, 2019 9:21 am
by TribunMaximus
OK, thats what I've done. And Oscam said connecten (0of39 cards).

The the last two entries of the live log:

Code: Select all

2019/05/02 11:15:00 43807ADB p   (reader) adress: resolved ip=xxx.x.xxx.x
2019/05/02 11:15:00 43807ADB p   (reader) share [cccam] connecting to adress:port
2019/05/02 11:15:00 43807ADB p   (reader) share [cccam] proxy initialized, server adress:prt
So, this seems to be fine.

What are the correct settings which needs to be done in dvbjam.readers to work with Oscam? Is there an error with my settings in dvbjam.readers:

Code: Select all

[reader]
label                         = share
protocol                      = cccam
device = adress, port
user = username
password = password
group                         = 1
disablecrccws                 = 1
cccversion                    = 2.3.0
blockemm-g = 1
audisabled = 1
enable     = 1

Thanks for your help.

Br

Re: TVMosaic, Windows10, Oscam

Posted: Thu May 02, 2019 9:45 am
by Oberon
What is exactly the issue?

Re: TVMosaic, Windows10, Oscam

Posted: Thu May 02, 2019 10:56 am
by TribunMaximus
It seems that Oscam is running and TVMosaic ist running fine as well as long if I don't change to encrypted channels.
If I change to encrypted channels the screen freezes until I change back to a normal channel.

Re: TVMosaic, Windows10, Oscam

Posted: Thu May 02, 2019 3:26 pm
by TribunMaximus
OK, a few step further:

Oscam Server running
TVMovie Server running
Most encrypter channels: running

But SKY-Channels are still not runnig in TV Mosaic. But in other programms there are running.
Any idea what needs to be changed?

Br
Jens

Re: TVMosaic, Windows10, Oscam

Posted: Tue Oct 08, 2019 12:08 am
by gompf
Hi,

the solution to this issue is one line which needs to be added (provided that your server side config is already configured accordingly):

Code: Select all

disablecrccrws = 1
Which makes it compatible with recent sky changes across all platforms. Works well here. Please note spelling of this keyword (disablecrccrws)for DVBJCAM is different from the respective Keyword in OSCAM.

/Gompf

Re: TVMosaic, Windows10, Oscam

Posted: Wed Oct 09, 2019 1:10 pm
by TribunMaximus
Sorry, to ask again to get a clear understanding:

1.) All I need is a running OSCAM config on a server. In my case my server is not the server which is sharing the keys - I only use OSCAM to get all needed keys from another server.

Code: Select all

2019/10/09 14:56:34 00000000 s     (main) Host name      = XXXXXXX
2019/10/09 14:56:34 00000000 s     (main) Release        = 2.11.2(0.329/5/3)
2019/10/09 14:56:34 00000000 s     (main) Version        = 2018-11-08 14:34
2019/10/09 14:56:34 00000000 s     (main) Machine        = x86_64
2019/10/09 14:56:34 00000000 s couldn't open statistics file: /tmp/user.log
2019/10/09 14:56:34 00000000 s      (emu) OSCam-Emu version 795
2019/10/09 14:56:34 00000000 s   (config) userdb reloaded: 1 accounts loaded, 0 expired, 0 disabled
2019/10/09 14:56:34 00000000 s     (main) signal handling initialized
2019/10/09 14:56:34 00000000 s   (reader) XXXX[cccam] creating thread for device SERVER_ADRESS.ORG
2019/10/09 14:56:34 00000000 s   (reader) emulator [emu] creating thread for device emulator
2019/10/09 14:56:34 00000000 s (emmcache) loading emmcache disabled since no reader is using it!
2019/10/09 14:56:34 00000000 s (emmcache) loading emmstats disabled since no reader is using it!
2019/10/09 14:56:34 00000000 s (anticasc) anti cascading disabled
2019/10/09 14:56:34 67DE504B r      (emu) Stream key delayer initialized
2019/10/09 14:56:34 00000000        (emu) INFO: FFDecsa parallel mode = 128
2019/10/09 14:56:34 67DE504B r      (emu) Stream relay server initialized
2019/10/09 14:56:34 67DE504B r   (reader) emulator [emu] Reader initialized (device=emulator, detect=cd, mhz=357, cardmhz=357)
2019/10/09 14:56:34 100E6977 c   (client) plain dvbapi-client granted (dvbviewer, au=auto (2 reader))
2019/10/09 14:56:34 5851F42D h    (webif) webif: decompressed 178917 bytes back into 440112 bytes
2019/10/09 14:56:34 5851F42D h    (webif) HTTP Server running. ip=0.0.0.0 port=8080
2019/10/09 14:56:34 100E6977 c   (dvbapi) dvbapi channelcache loaded from /cygdrive/c/ProgramData/mdvbapi/oscam_win/oscam.ccache
2019/10/09 14:56:34 100E6977 c   (dvbapi) Using TCP listen socket, API forced to DVBAPIv3 (0), userconfig boxtype: 11
2019/10/09 14:56:34 35234D7A p   (reader) SERVER_ADRESS.ORG: resolved ip=XXX.X.XXX.XXX
2019/10/09 14:56:34 35234D7A p   (reader) XXXX [cccam] connecting to SERVER_ADRESS.ORG:PORT
2019/10/09 14:56:34 35234D7A p   (reader) XXXX [cccam] proxy initialized, server SERVER_ADRESS.ORG:PORT
2019/10/09 14:56:35 67DE504B r   (reader) emulator [emu] card detected
2019/10/09 14:56:36 67DE504B r   (reader) emulator [emu] found card system emu
2019/10/09 14:56:36 67DE504B r   (reader) emulator [emu] THIS WAS A SUCCESSFUL START ATTEMPT No  1 out of max allotted of 1
2019/10/09 14:56:36 67DE504B r      (emu) Key file not found in: /cygdrive/c/ProgramData/mdvbapi/oscam_win
2019/10/09 14:56:36 67DE504B r      (emu) Cannot open key file path: /var/keys
2019/10/09 14:56:36 67DE504B r      (emu) Total keys in memory: W:0 V:0 N:0 I:0 S:0 F:0 G:0 P:0 D:0 T:0 A:0
2019/10/09 14:57:13 35234D7A p   (reader) XXXX[cccam] disconnected: reason inactivity
OSCAM.SERVER

Code: Select all

[reader]
label                         = XXXX
protocol                      = cccam
device                        = SERVER_ADRESS.ORG,PORT
user                          = USER4711
password                      = PASSWORD4711
inactivitytimeout             = 30
disablecrccws_only_for        = 0500:050F00;09C4:000000;098C:000000;098D:000000
group                         = 1
disablecrccws                 = 1
cccversion                    = 2.3.0

[reader]
label                         = emulator
protocol                      = emu
device                        = emulator
disablecrccws_only_for        = 0E00:000000
caid                          = 0500,0604,090F,0E00,1010,1801,2600,2602,2610,4AE1
detect                        = cd
ident                         = 0500:000000,007400,007800,021110,023800;0604:000000;090F:000000;0E00:000000;1010:000000;1801:000000,001101,002111,007301;2600:000000;2602:000000;2610:000000;4AE1:000011,000014,0000FE
group                         = 1
emmcache                      = 2,1,2,1
emu_auproviders               = 0604:010200;0E00:000000;1010:000000;2610:000000;4AE1:000011,000014,0000FE

I think thats correct.
Do I need the emulator or can I delete this part?

2.) DVBJCAM: is located in the data/devives/devicename/Plugins directory:

Code: Select all

[reader]
label= XXXX
protocol= cccam
device = SERVERADRESS??, PORT
user = USER??
password = PASSWORD??
group = 1
//cccversion = 2.3.0
ccversion = 2.2.1
ccckeepalive = 1
disablecrccws = 1
disablecrccws_only_for = 0500:50F000;09C4:000000;098C:000000;098D:000000
Regarding serveradress??, user?? and passwort?? the question: Should this be the same serveradress as in the OSCAM.CONFIG (SERVER_ADRESS.ORG, USER4711 and PASSWORD4711) in my case?
Or do I need to install something else on my LOCAL server?

Sorry for the question but the logic of DVBJCAM is not clear for my.

Thanks for your help

Br
Jens